Cannot upload files in Uploader (Mac)

I just downloaded and installed the Map the Paths Uploader for Mac (using the .dmg from GitHub, version 0.0.1). When creating a new sequence, I get to the point where I have to upload the photos. The file selection window opens up correctly, but I cannot select any files - they remain grayed out. I have valid .jpg and .jpeg files, tried all sorts of other formats too. I also tried video instead of images, same issue. It does allow me to select an entire folder, but then it throws the error that is is not a valid jpg file.

I am on Catalina 10.15.6

Really looking forward to use this software! :slight_smile:

On Win10 you select the folder that contains the files.

Hey @RadioBaobab,

Can you share the 2 of the jpg files with me, either here or via email?

I have seen something like this in testing but could not recreate for a second time, so this would help me identify any potential bug.

Ok, so I’ve done some more testing. I understand now that the intended way for it to work is that you have to select the folder - and not the files. That explains the grayed out files :slight_smile:

  • When I have a folder with ONLY jpg’s in them: Works fine!! Excellent :slight_smile:
  • When there is a subfolder in there: Error: The images should be jpeg or jpg
  • When there is any other file in there: Error …

So that’s good, just some extra checking on the folder contents should fix that in the future :slight_smile:

But then, when I try the same for files residing on Google Drive (with Google Drive File Stream): Error in all of the same above scenario’s (I copied over the entire folder structure that works when residing on a local harddrive).

So there you go. As long as the images are in a folder on their own on a local drive, everything works fine.

Keep up the good work!

I was a bit too fast with my conclusion of it working when those conditions were met.
It worked once. But now, whenever I manage to successfully select a folder to meets te conditions, I get the following error:

EEXIST: file already exists, mkdir ‘/Application/Map the Paths Uploader.app/Contents/Resources/sequences/test67’

I have checked that file location, and the folder test67 (name of my sequence) contains a subfolder “originals” with all the files that I selected in the gui.

I have also tried to create a fully new sequence with a different name: same issue (but the error then include the new sequence name)
And I also tried to rename the folder test67 and tried uploading again, but the error remains (and it puts the file in that location again)

— EDIT —

there is some randomness to my issues. I just closed the uploader completely and tried again: it works now.

If you want me to do further testing, do let me know.

Thanks @RadioBaobab this is very useful. I should be able to push a new fix tomorrow for this.

Please do keep testing – this is really useful, thank you!

Hello, here is another issue:

When trying to upload a video (as compared to a series of photos), the application throws the error: /bin/sh ffmpeg: command not found.

As far as I can see, there are 2 issues:

  1. It seems that ffmpeg is not bundled within the installation package (or is not correctly called, I did not check). I have a fairly fresh install of MacOS, and ffmpeg is not a standard tool. I installed ffmpeg myself, but the error remained. Probably because of:
  2. I think the syntax when calling ffmpeg is wrong in combination with calling /bin/sh. When executing a binary file, the syntax should be /bin/sh -c ffmpeg. Without the -c, it would only execute scripts.

I might be wrong, I am not a developer :slight_smile:

Here is the screenshot of the full error:

And another more trivial issue on Mac: there is no way to gracefully exit the program. Command-Q is not mapped, and there is not an exit option in the menu.

Thanks @RadioBaobab this is a critical issue and I have managed to recreate.

Attempting a fix ASAP. Please give me a few days – sorry this week has been a little busy for me.

Thanks for your continued support (and patience!).

HQ | Blog | Spotted a Trekker? | Become a Trekker | Facebook | Instagram